[AstroPy] Pyfits writeto w/ clobber

Rene Breton superluminique@gmail....
Tue Sep 14 18:09:32 CDT 2010


Hi Fabricio,

I'm also on Ubuntu 10.04 and the version of pyfits in the repository is indeed very old; v1.3. I would highly recommend that you install pyfits manually from the tarball there: http://www.stsci.edu/resources/software_hardware/pyfits/Download. Perhaps pypi has a pyfits bundle but I haven't checked.

Rene


On 2010-09-14, at 6:49 PM, Fabricio Ferrari wrote:

> Dear Jim
> 
> Of course you are right, pyfits 1.3 is very old. But I have ubuntu
> 10.04 with pyfits from the repository.
> It should be a newer version, I really don't know what happened.
> 
> If I do:
>     import pyfits
>     print pyfits.__version__
> 
> I got the 1.3 version
> 
> Does anyone has a similar problem?
> 
> Thanks
> Fabricio
> 
> ..-. ..-.
> Fabricio Ferrari       [www.ferrari.pro.br]
> Brasil
> 
> 
> 
> 2010/9/14  <jtaylor2@stsci.edu>:
>> Fabricio,
>> 
>>    I don't know about version 1.3 of pyfits which is several years old, but the current version is 2.3.1 and the clobber argument to pyfits.writeto() works correctly.  You may get the latest version of pyfits from http://www.stsci.edu/resources/software_hardware/pyfits/Download.
>> 
>>     Jim T.
>> 
> _______________________________________________
> AstroPy mailing list
> AstroPy@scipy.org
> http://mail.scipy.org/mailman/listinfo/astropy



More information about the AstroPy mailing list