[AstroPy] error building astropy on Lion

Tim Jenness tim.jenness@gmail....
Wed Jun 20 11:50:12 CDT 2012


On Wed, Jun 20, 2012 at 9:41 AM, Jean-Claude Passy <jcpassy@gmail.com> wrote:

> ----------------------------------------------------------------- [12:36:08]
> Astrobook2:$ /usr/bin/gcc --version i686-apple-darwin11-llvm-gcc-4.2 (GCC)
> 4.2.1 (Based on Apple Inc. build 5658) (LLVM build 2336.9.00)
> -----------------------------------------------------------------
> and
>
> ----------------------------------------------------------------- [12:37:14]
> Astrobook2:$ which gcc /opt/mesasdk/bin/gcc [12:37:17] Astrobook2:$ gcc
> --version gcc (GCC) 4.7.0 20111114 (experimental)
> -----------------------------------------------------------------
> The gcc 4.7 is part of a package I had to install for another code. This is
> why I used $CC to specify which compiler to use.
>

but the compile line says it's using plain "gcc" rather than
"/usr/bin/gcc" so it seems to be picking up your experimental
compiler. If you remove /opt/mesasdk/bin from your path do things
build ok?

-- 
Tim Jenness


More information about the AstroPy mailing list