[AstroPy] External packages in astropy

Perry Greenfield perry@stsci....
Wed Jun 20 14:36:30 CDT 2012


On Jun 20, 2012, at 3:19 PM, Olе Streicher wrote:

> Michael Droettboom <mdroe@stsci.edu> writes:
>
>> I have been told by the upstream author that MS-Windows compatibility
>> is not something he cares about.
>
> This is also not python specific. Also, for distribution packaging
> Windows patches are not interesting.
>
Perhaps not for unix packaging, but for windows packaging, it sure is.  
Just because you don't care doesn't mean we shouldn't (and besides, we  
have to patch it anyway for SIP).

> To summarize: pywcs works well with the original wcslib (especially  
> the
> latest, bugfixed versions), and it has the same limitations as the  
> used
> wcslib. If one wants to use SIP, he needs to use a patched wcslib,
> regardless of the programming language (Python or C). Right?
>
Yes. But I'm not sure what your point is. There are many projects that  
use SIP so doing without it isn't feasible. Yes, we could release  
patched version under a different name, but we aren't in the business  
of making a "better" version of wcslib available, nor do we want to  
incur the possible political headaches of appearing to compete with  
the original.

Cheers, Perry




More information about the AstroPy mailing list