[AstroPy] package requirements for pyregion

Tom Aldcroft aldcroft@head.cfa.harvard....
Sat Jun 23 19:00:43 CDT 2012


On Fri, Jun 22, 2012 at 4:03 PM, Vicky Scowcroft
<vs@obs.carnegiescience.edu> wrote:
> Hi,
> I'm following the setup instructions at
> http://python4astronomers.github.com/installation/python_install.html
>
> Under "MacOS or root linux install" you have:
>
> sudo pip install --upgrade pyregion
>
>
> This doesn't work without the pyrex package,
> so
>
> sudo pip install --upgrade pyrex
>
> should be added before.
>
> Thanks
> Vicky
>
> _______________________________________________
> AstroPy mailing list
> AstroPy@scipy.org
> http://mail.scipy.org/mailman/listinfo/astropy
>

Hi Vicky,

Thanks for the feedback.  This was already reported and being tracked
[1], but we'll get on it.  As mentioned in the issue, the dependency
can be met with Cython and that is probably a better option at this
point.   Also, it looks like pyregion is supposed to build without
Pyrex or Cython [2], but this doesn't seem to work and may be a
pyregion issue.

- Tom

[1] https://github.com/python4astronomers/python4astronomers/issues/6
[2] https://github.com/leejjoon/pyregion/commit/ff785c85464d4ef912931037beca8c47c7674e53


More information about the AstroPy mailing list