<html>
  <head>
    <meta content="text/html; charset=ISO-8859-1"
      http-equiv="Content-Type">
  </head>
  <body bgcolor="#FFFFFF" text="#330000">
    Hi Joe,<br>
    <br>
    If Taro's suggestion isn't working for you, let me know off list.&nbsp;
    There are a few different options to get this to work the way you
    need.<br>
    <br>
    And if there is a bug (or "unexpected feature"), we'd like to fix
    it.<br>
    <br>
    Finally, I believe we can get EPAR to do what you want, but to
    answer your question about a non-GUI version, yes, you can try
    "tpar" in PyRAF, for a terminal version (it requires the "urwid"
    package).<br>
    <br>
    Chris<br>
    <br>
    On 1/7/12 2:23 AM, Joe Philip Ninan wrote:
    <blockquote
cite="mid:CAJ_T+b4Qz=cuAq07-iNZY30TyL_WS64UWHr=4tK7icXr28bAYQ@mail.gmail.com"
      type="cite">
      <pre wrap="">Hi,
I have been recently rewriting to pyraf all my photometry iraf scripts.
For using the daofind and then phot task in noan.digiphot.daophot we
first have to set the parameter files.
Following is that section from my code.
#--------------------(all the variables fwhm psfradi sigma datamin
aperture etc. have been defined before in code)---------
&nbsp;&nbsp;&nbsp; iraf.daopar(matchra=fwhm, psfrad=psfradi, fitrad=fwhm)
&nbsp;&nbsp;&nbsp; iraf.datapar(fwhmpsf=fwhm, sigma=sigma, datamin=datamin,
datamax=65000 , readnoi=4.8 , epadu=1.22 ,itime=intime,
ifilter=filterr)
&nbsp;&nbsp;&nbsp; iraf.fitskypar(annulus=270, dannulu=12 )
&nbsp;&nbsp;&nbsp; iraf.photpar(apertur=aperture)
&nbsp;&nbsp;&nbsp; iraf.daofind(image=img)
&nbsp;&nbsp;&nbsp; #Going forward to do phot
&nbsp;&nbsp;&nbsp; iraf.phot(image=img)
#----------------------------------------------------
Now , when I run this code. It does displays the epar daopar, datapar
etc in the GUI epar window of the pyraf with all correct values set.
But when I press "Save &amp; Quit" button and reaches the daofind or phot
task. It is executing without all the seted parameters.
It looks like inspite of me clicking on "Save &amp; Quit" button. It is
not getting saved. and the phot and daofind task are using some
default setting in my uparm/
In iraf, I had the same problem if i gave :wq in epar. But if I gave
:w and then :q separately it used to work.
There is no :w equivalent button in pyraf's GUI epar window.

Can somebody point out some workaround for this problem? Is it
possible in pyraf to get the non GUI epar window of iraf?
Thanking you
Joe

--
/---------------------------------------------------------------
"GNU/Linux: because a PC is a terrible thing to waste" -&nbsp; GNU Generation
_______________________________________________
AstroPy mailing list
<a class="moz-txt-link-abbreviated" href="mailto:AstroPy@scipy.org">AstroPy@scipy.org</a>
<a class="moz-txt-link-freetext" href="http://mail.scipy.org/mailman/listinfo/astropy">http://mail.scipy.org/mailman/listinfo/astropy</a>
</pre>
    </blockquote>
  </body>
</html>