<html dir="ltr">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
<style id="owaParaStyle">P {
        MARGIN-TOP: 0px; MARGIN-BOTTOM: 0px
}
</style>
</head>
<body fPStyle="1" ocsi="0">
<div style="direction: ltr;font-family: Tahoma;color: #000000;font-size: 10pt;">
<p>I tried following the instructions given in&nbsp;the Installing Scientific Python tutorial (<a href="http://python4astronomers.github.com/installation/python_install.html">http://python4astronomers.github.com/installation/python_install.html</a>)&nbsp;after installing
 the current EDP academic version (EDP-7.3-2) of python 2.7 on my Windows system (7 Home Premium ver 6.1 build 7601 SP1) without any problems, but&nbsp;get&nbsp;error messages when attempting the 'Install Additional Packages' commands&nbsp;the tutorial lists&nbsp;for Windows:</p>
<p>&nbsp;</p>
<p><font face="Courier New">Enthought Python Distribution -- </font><a href="http://www.enthought.com"><font face="Courier New">www.enthought.com</font></a></p>
<p><font face="Courier New">Python 2.7.3 |EPD 7.3-2 (32-bit)| (default, Apr 12 2012, 14:30:37) [MSC v.1500 3<br>
.</font></p>
<p><font face="Courier New">.</font></p>
<p><font face="Courier New">.</font></p>
<p><font face="Courier New">Welcome to pylab, a matplotlib-based Python environment [backend: WXAgg].<br>
For more information, type 'help(pylab)'.</font></p>
<p><font face="Courier New">In [1]: cd C:\Python27\Scripts<br>
C:\Python27\Scripts</font></p>
<p><font face="Courier New">In [2]: easy_install.exe --upgrade pip<br>
&nbsp; File &quot;&lt;ipython-input-2-9ddc46f55be3&gt;&quot;, line 1<br>
&nbsp;&nbsp;&nbsp; easy_install.exe --upgrade pip<br>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; ^<br>
SyntaxError: invalid syntax</font></p>
<p><br>
<font face="Courier New">In [3]: pip.exe install --upgrade distribute<br>
&nbsp; File &quot;&lt;ipython-input-3-5a79986fb019&gt;&quot;, line 1<br>
&nbsp;&nbsp;&nbsp; pip.exe install --upgrade distribute<br>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; ^<br>
SyntaxError: invalid syntax</font></p>
<p><br>
Any hints on what to do? Is the tutorial out of date?</p>
<p>&nbsp;</p>
<p>I also get some error messages when running the commands the tutorial provides in the 'Test your installation' section:</p>
<p>&nbsp;</p>
<p><font face="Courier New">In [4]: % python -V<br>
ERROR: Magic function `python` not found.<br>
In [5]: % ipython -V<br>
ERROR: Magic function `ipython` not found.<br>
In [6]: % ipython -pylab<br>
ERROR: Magic function `ipython` not found.<br>
In [7]: import numpy</font></p>
<p><font face="Courier New">In [8]: import scipy</font></p>
<p><font face="Courier New">In [9]: import scipy.linalg</font></p>
<p><font face="Courier New">In [10]: print numpy.__version__<br>
1.6.1</font></p>
<p><font face="Courier New">In [11]: print scipy.__version__<br>
0.10.1</font></p>
<p><font face="Courier New">In [12]: print matplotlib.__version__<br>
1.1.0</font></p>
<p>&nbsp;</p>
<p>And since the easy_install.exe upgrade didn't work, I can't install some of the required packages:</p>
<p>&nbsp;</p>
<p><font face="Courier New">In [13]: import asciitable<br>
---------------------------------------------------------------------------<br>
ImportError&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Traceback (most recent call last)<br>
C:\Python27\Scripts\&lt;ipython-input-13-4cd71165d355&gt; in &lt;module&gt;()<br>
----&gt; 1 import asciitable</font></p>
<p><font face="Courier New">ImportError: No module named asciitable</font></p>
<p>&nbsp;</p>
<p>Is there a suitable forum that answers such newbie questions? </p>
</div>
</body>
</html>