[IPython-dev] GTK warning.

Andrea Riciputi ariciputi at pito.com
Wed Feb 23 08:05:32 CST 2005


The warning appears with both Gtk and GtkAgg. But probably you are 
right, it is a version problem. My pygtk/gtk and matplotlib are a 
little bit outdated. Unfortunately, the deadline for my PhD thesis is 
approaching and I have no time now to play with these sort of things. 
When the discussion will be over, I'll try to fix it and I'll let you 
know.

Thanks,
  Andrea.

On 23 Feb 2005, at 14:06, Fernando Perez wrote:

> Mmh.  What is your matplotlib backend? Gtk or GtkAgg?  I don't 
> directly use much of gtk, so it's possible that this is triggered by 
> the pylab backend code.
>
> I should also note that under linux (fedora3) I don't see it, so it 
> may well be a pygtk/gtk version thing.
>
> If it continues to be a bother as you update versions of 
> pygtk/gtk/matplotlib,   I'd suggest informing the matplotlib list 
> directly, since I suspect this is on their side of things.
>
> Best,
>
> f




More information about the IPython-dev mailing list