[IPython-dev] Re: Python version

Fernando Perez Fernando.Perez at colorado.edu
Tue Jul 19 12:28:24 CDT 2005


Robert Kern wrote:
> Fernando Perez wrote:
> 
> 
>>In summary, if @decorators and such really are helping the readability 
>>and clarity of the code, keep 2.4.  I'll adapt.
> 
> 
> 2.4 features I use:
> 
> * @classmethod: easily replaced
> * builtin set(): easily replaced
> * generator expressions: [easily replaced], but oh, how I'll miss them
> * keyed sorts and sorted(): less easily replaced

Nah, keep 2.4 then.  I'll survive.

Let's keep the mainline ipython 2.2-safe, though.  That one is in real use out 
there, so I don't want to break things for existing users.  I've stuffed all 
2.2 compatibility symbols in genutils.py, so put in there anything you need 
which may be a backport from 2.3/4, if you touch ipython itself (this goes 
especially to Tzanko).

cheers,

f




More information about the IPython-dev mailing list