[IPython-dev] easy_install ipython==dev

Robert Kern robert.kern at gmail.com
Wed Feb 1 11:45:45 CST 2006


Fernando Perez wrote:

> ps - Just one recent example of the kind of things that make me so paranoid 
> about not letting ANY unnecessary setuptools dependency creep in:
> 
> <quote>
> Unfortunately I had trouble installing Django for the Python 2.5 alpha that 
> I've got installed; it uses the fancy new ez_install stuff, which is great 
> when it works, but there's no Python 2.5 download of setuptools on PyPI yet, 
> so it doesn't.
> </quote>
> 
> from Guido's blog:
> http://www.artima.com/weblogs/viewpost.jsp?thread=146606

It's an ez_setup.py bootstrap problem, not a real setuptools issue. Getting the
setuptools source and "python setup.py install"ing it works fine. After that,
anything else using setuptools should work fine with Python 2.5. Yet one more
reason not to use ez_setup.py, but not a reason to avoid setuptools itself.

-- 
Robert Kern
robert.kern at gmail.com

"In the fields of hell where the grass grows high
 Are the graves of dreams allowed to die."
  -- Richard Harter




More information about the IPython-dev mailing list