[IPython-dev] Patch to completer.py

Fernando Perez Fernando.Perez at colorado.edu
Sun Jan 8 13:59:32 CST 2006


Prabhu Ramachandran wrote:
> Hi Fernando,
> 
> I had send you a note off-list about an error with my earlier patch to
> support traits.  I haven't heard from you on that.  Attached is a
> patch.  I noticed that you are using set.  Set is part of Python-2.4.
> So is SVN only for 2.4?

Mmh, I hadn't replied because I never got your message.  I even checked my 
spam inbox for an accidental false positive, but nothing.  Weird.

In any case, I just applied and committed your attached patch, many thanks.

Sets are OK for 2.3 (though they're a module there), so it's no problem (my 
default python is 2.3, so I would have noticed :)

However, this just made me realize that we're not 2.2 compatible anymore...

I'm torn, b/c I've tried to keep 2.2 compatibility for a while, but I just 
realized there's more than the sets call now in ipython.  The sets use could 
easily be avoided with a dict, but there's more, and I don't even know what 
anymore.

So I suspect I'm going to punt and call 0.7.0 a python2.3-based release.  If 
anyone is still stuck with 2.2, I guess they'll just have to live with 0.6.15 
from now on...

I'm too close to a release, and too tight on time, to go hunting for every 
possible non-2.2 feature I may have inadvertedly left slip.

Oh well, 2.3 has been out for quite a while now.

Cheers,

f




More information about the IPython-dev mailing list