[IPython-dev] Patch to completer.py

Prabhu Ramachandran prabhu_r at users.sf.net
Sun Jan 8 22:13:21 CST 2006


>>>>> "Fernando" == Fernando Perez <Fernando.Perez at colorado.edu> writes:

    Fernando> Prabhu Ramachandran wrote:
    >> Hi Fernando,
    >>
    >> I had send you a note off-list about an error with my earlier
    >> patch to support traits.  I haven't heard from you on that.
    >> Attached is a patch.  I noticed that you are using set.  Set is
    >> part of Python-2.4.  So is SVN only for 2.4?

    Fernando> Mmh, I hadn't replied because I never got your message.
    Fernando> I even checked my spam inbox for an accidental false
    Fernando> positive, but nothing.  Weird.

Very wierd.  The message headers should have had this:

 Date: Thu, 5 Jan 2006 23:38:34 +0530
 To: Fernando . dot . Perez [ at ] colorado . dot . edu
 Subject: Error in the patch to support traits.

My MTA logs claim that the message was delivered to the smarthost
here.

    Fernando> In any case, I just applied and committed your attached
    Fernando> patch, many thanks.

Thanks!

    Fernando> Sets are OK for 2.3 (though they're a module there), so
    Fernando> it's no problem (my default python is 2.3, so I would
    Fernando> have noticed :)

Right, I did not look hard enough for set and somehow had the
impression that set is 2.4 only.

    Fernando> However, this just made me realize that we're not 2.2
    Fernando> compatible anymore...
[...]
    Fernando> Oh well, 2.3 has been out for quite a while now.

Yes, 2.3 is fine.  I should have moved to 2.4 but there is so much to
do...

regards,
prabhu




More information about the IPython-dev mailing list