[IPython-dev] Problem with gtk/pylab (with SVN)

Prabhu Ramachandran prabhu_r at users.sf.net
Wed Jan 11 00:27:15 CST 2006


Hi, 

I get this error when I use the GTKAgg backend and pylab.

$ ipython -pylab
pygtk.require() must be called before importing gtk
PyGTK version 1.99.16 or greater is required to run the GTK Matplotlib backends

OTOH, this works:

$ ipython -gthread

Matplotlib version 0.82?  Is this a matplotlib bug?  BTW, things work
fine with the WXAgg backend.  I just thought that if this was a bug in
IPython that you should know.

cheers,
prabhu




More information about the IPython-dev mailing list