[IPython-dev] Problem with gtk/pylab (with SVN)

John Hunter jdhunter at ace.bsd.uchicago.edu
Wed Jan 11 08:21:39 CST 2006


>>>>> "Prabhu" == Prabhu Ramachandran <prabhu_r at users.sf.net> writes:

    Fernando> Given that I don't see it with 0.83, and others in the
    Fernando> mpl list aren't reporting any problems (all most likely
    Fernando> running more recent mpl versions), it really may be an
    Fernando> issue that would just go away with an mpl upgrade.

You just need to make sure that neither matplotlib (in backend_gtk.py)
or IPython (in Shell.py).

Just remove all these and you should be fine.

Basically, pygtk.require should not be used in any code that may be
used in a library, such as mpl or ipython...

JDH




More information about the IPython-dev mailing list