[IPython-dev] Issue with upgrading from 0.6.15 to 0.7.0 via easy_install

Robert Kern robert.kern at gmail.com
Thu Jan 12 10:56:04 CST 2006


Travis Caldwell wrote:

> After blowing away PYTHONPATH, 0.7.0 worked just fine.

Excellent.

> (I also didn't realize that the egg's in site-packages are actually
> directories. If I had realized that I could just 'cd' into them, I
> wouldn't have messed with the setuptools API)

It depends. If the package is not "zip-safe", then easy_install will unzip the
egg appropriately. ipython is not zip-safe (and that's okay).

-- 
Robert Kern
robert.kern at gmail.com

"In the fields of hell where the grass grows high
 Are the graves of dreams allowed to die."
  -- Richard Harter




More information about the IPython-dev mailing list