[IPython-dev] IPython 0.7.1.rc1 is ready

Fernando Perez Fernando.Perez at colorado.edu
Sun Jan 22 23:39:26 CST 2006


Prabhu Ramachandran wrote:

> It looks like the 0.7.1 branch has Python 2.4 dependencies in the form
> of decorators.
> 
> byte-compiling /usr/local/stow/ipython/lib/python2.3/site-packages/IPython/Extensions/ext_rehashdir.py to ext_rehashdir.pyc
>   File "/usr/local/stow/ipython/lib/python2.3/site-packages/IPython/Extensions/ext_rehashdir.py", line 32
>     @ip.asmagic("rehashdir")
>     ^
> SyntaxError: invalid syntax
> 
> Otherwise, things seem to look OK.

Ville?  We're certainly keeping 2.3 compatibility in trunk.    I didn't write 
that code, and right now I won't be able to look at it.  I plan on cutting the 
release tomorrow, so if you have a chance to fix these by then, great. 
Otherwise I'll just delete all that code from this branch, and you can fix it 
later in trunk/ to not require 2.4.

Decorators are just syntactic sugar, so for now the functionality can be 
obtained in a 2.3-compatible manner.

To be clear: ipython trunk will remain, for the foreseeable future, 2.3 
compatible.  The chainsaw branch does require 2.4.

Thanks for catching this one, Prabhu.

Cheers,

f




More information about the IPython-dev mailing list