[IPython-dev] Extensions & version dependency

Ville Vainio vivainio at gmail.com
Mon Jan 23 05:05:00 CST 2006


On 1/23/06, Fernando Perez <Fernando.Perez at colorado.edu> wrote:

> Yeah, and even if it's an extension, we want users of ipython to be able to
> access all of its features.  I don't want to tell them 'this subset of ipython
> requires 2.4'.

I think we can refrain from making extensions dependent on syntax of
new python versions, but I'm not so sure about libraries (esp. if a
version of the library can be installed on older python versions).

I'm thinking of writing an extension for some level of job control
(processes, not threads) using the "subprocess" module one of these
days.

--
Ville Vainio - http://tinyurl.com/2prnb
http://vainio.blogspot.com




More information about the IPython-dev mailing list