[IPython-dev] [Fwd: python2.5]

Ville Vainio vivainio at gmail.com
Tue Jul 25 02:09:27 CDT 2006


On 7/25/06, Fernando Perez <Fernando.Perez at colorado.edu> wrote:

> Anyway, I understand that IPython makes no claims at all about
> supporting Python 2.5.   I just wanted to let you know that Python 2.5
> seems to be a huge jump, so much so that somebody might have to put
> in some significant effort to make IPython work with it.

Thanks for the heads up.

It's clearly a priority to get it working on python 2.5, but the whole
deal seems to be a regression for python 2.5 rather than an indication
for a need to "fix" ipython. I.e. there's something badly wrong w/
python 2.5 if it breaks lots of stuff (w/o "from __future__ import
blah blah", or deprecationwarnings), and knowing that it flies against
the traditional conservative evolution b/w python versions, one would
expect that future betas of python 2.5 will work better.

-- 
Ville Vainio - vivainio.googlepages.com
vainio.blogspot.com - g[mail | talk]='vivainio'


More information about the IPython-dev mailing list