[IPython-dev] error in ipython 0.8

Fernando Perez fperez.net@gmail....
Wed Apr 11 08:28:23 CDT 2007


On 4/11/07, Aldarion <erendisaldarion@gmail.com> wrote:
> same error here,
> windows server 2003,IPython0.8 + pyreadline1.3 (+ python2.5)
> and:
>     IPtyhon 0.73/0.74rc1 works fine with pyreadline1.3
>     IPython 0.73/0.74rc1 can't load pyreadline1.4svn
>     Ipython 0.80 failed load pyreadline1.4svn (can't stop printing a lot
> of error info...)

ARGH: I didn't realize (since my windows box died completely and I
couldn't test there) that 0.8.0 relies on the API from pyreadline 1.4.
 But pyreadline 1.4 isn't out yet because Jorgen has been busy this
week: there's a problem with its setup.py file that creates an
incomplete installer.

For now, the only solution is for win32 users to NOT upgrade.  I'll be
gone on travel for a few days, but I can sneak into the server to
upload pyreadline as soon as Jorgen (or anyone else who can test on
win32) updates its setup.py file to produce a proper installer.

I moved the win32 installer out of the way (to testing/) for now.

Huge apology about this.

Regards,

f


More information about the IPython-dev mailing list