[IPython-dev] wxIPython 0.6 (Multithreaded and current bug list flushed)

Laurent Dufrechou laurent.dufrechou@gmail....
Wed Dec 12 07:25:18 CST 2007


>Yes, the traceback is in color and seems to render OK.
>
>If I change the bg to white and fg to black things are better.  BTW, I 
>can see output text just fine, just the input line is broken.
>
>[...]

Ok will check this tonight. As I haven't try under linux, must have a lot of
bug ;)

>Ahh, cool, this fixes it and I can use Python.  However, I just did this:
>
>import string
>string??
>
>and get a core dump!  Otherwise if I do this:
>
>?
>
>I get the help on the terminal and not on the wx shell.  If I do !ls for 
>example the output is listed on the shell I launched the wxIPython shell 
>from.  If I hit tab, I get completion (on the wx widget) but I also 
>loose keyboard focus.

Oups :) I forget to try the '??' key, will check this too.
For the'!' It's a boring problem I had to solve on windows (I mean redirect
output to wx...), so I need to check this for linux...
Hum, seems under linux there is big issue whith std redirection... arfff, I
was thinking I had solved the issue...too bad :)
Ok for the TAB.

> 
> Can you please send me the result of: 
> Import locale
> print locale.getdefaultlocale()?

In [1]: import locale

In [2]: print locale.getdefaultlocale()
(None, None)

Ok... mine outputs: ('fr_FR', 'cp1252').
>From what I've just checked,under linux it works differently...
Good :)
My bug list is now almost refilled thanks to you ;)
I'll tell you if I need more info!

Thanks!
Laurent



More information about the IPython-dev mailing list