[IPython-dev] Setup problem with ipython1

Fernando Perez fperez.net@gmail....
Thu Feb 22 13:51:07 CST 2007


Hi David,

On 2/22/07, David Huard <david.huard@gmail.com> wrote:
> Hi,
>
> I just updated the saw branch and I have problems with the installation;
> it complains about being unable to import ipython1.external.
>
> I added a ipython1/external/twisted/web2 to `with_packages` in setup.py,
> but then, by calling import ipython1.kernel.api I get
>
> /usr/local/lib/python2.4/site-packages/ipython1/external/twisted/web2/__init__.py
>       9
>      10 """
>      11
> ---> 12 from ipython1.external.twisted.web2._version import version
>      13 __version__ = version.short()
>
> /usr/local/lib/python2.4/site-packages/ipython1/external/twisted/web2/_version.py
>       1 # This is an auto-generated file. Use admin/change-versions to update.
> ----> 2 from twisted.python import versions
>       3 version = versions.Version(__name__[:__name__.rfind('.')], 0, 2, 0)
>
> my twisted version is 2.2.0, is this outdated ?

Yes, I'm afraid so.  Twisted 2.5.0 is required for this to run.

Having said that, saw is currently undergoing massive changes, so I'd
recommend waiting until next week for the dust to settle just a
little.  That's why we haven't really announced much of anything
publicly yet :)

Cheers,

f


More information about the IPython-dev mailing list