[IPython-dev] ipython1 / python 2.3

danmil@comcas... danmil@comcas...
Tue Mar 27 08:56:12 CDT 2007


This (requiring 2.4) seems totally reasonable to me.  I just got confused by some of the docs.

I'll go get those pesky Zope Interfaces working now...
-Dan

 -------------- Original message ----------------------
From: "Fernando Perez" <fperez.net@gmail.com>
> On 3/26/07, Dan Milstein <danmil@comcast.net> wrote:
> > Just an FYI -- ipython1 doesn't run on python 2.3.
> 
> Yup.
> 
> > Should it?
> 
> Well, we've more or less settled on using 2.4 for it.  I know Brian is
> making more and more use of decorators for a number of things that are
> making his life easier, so it's quite likely that 2.4 will remain a
> 'hard' requirement.  I guess if there's major demand for 2.3 support
> we could look into it, since decorators are in the end 'just'
> syntactic sugar.  But it's quite possible that the amount of retrofit
> work needed becomes too much, in the face of already thinly-spread
> developer resources.
> 
> There's the additional issue of testing: ubuntu Edgy doesn't even
> /have/ an out of the box 2.3 python supplied, which for me would mean
> building a separate 2.3 and surrounding support libraries by hand.
> Doing so is trivial, but it's another time slot that I simply may not
> have.  When deciding on where to spend some dev time, between working
> on the code itself and doing 2.3 build work, I'm *very* likely to
> ditch the 2.3 support.
> 
> Basically right now the situation is just one of developer resources:
> I'd be happy supporting 2.3, but it's not likely to come from me.
> 
> For ipython trunk, we DO keep 2.3 as a supported version, and that
> will continue to be true for 0.7.4 and a possible release after that.
> 
> Cheers,
> 
> f



More information about the IPython-dev mailing list