[IPython-dev] building current bzr trunk :

Johann Cohen-Tanugi cohen@slac.stanford....
Tue Jun 10 13:49:22 CDT 2008



Brian Granger wrote:
> IPython should run fine with these older version of twisted and
> zope.interface.  But, I would like to try to understand what the
> problem is.  I am going to look at this and get back to you shortly.
> Two other questions:
>
> 1) What version of setuptools are you running?
>   
[root@jarrett ~]# rpm -qa | grep setuptools
python-setuptools-0.6c7-2.fc8
python-setuptools-devel-0.6c7-2.fc8

> 2) Can you retry with swig uninstalled?
>
>   
same thing :
[root@jarrett ~]# rpm -qa | grep swig
swig-1.3.33-1.fc8
[root@jarrett ~]# rpm --erase swig-1.3.33-1.fc8
[root@jarrett ~]# easy_install Foolscap
Searching for Foolscap
Best match: foolscap 0.2.8
Processing foolscap-0.2.8-py2.5.egg
foolscap 0.2.8 is already the active version in easy-install.pth
Installing flogtool script to /usr/bin

Using /usr/lib/python2.5/site-packages/foolscap-0.2.8-py2.5.egg
Processing dependencies for Foolscap
Searching for zope.interface
Reading http://pypi.python.org/simple/zope.interface/
Reading http://zope.org/Wikis/Interfaces/FrontPage
Best match: zope.interface 3.4.1
Downloading 
http://pypi.python.org/packages/source/z/zope.interface/zope.interface-3.4.1.tar.gz#md5=b085f4a774adab688e037ad32fbbf08e
Processing zope.interface-3.4.1.tar.gz
Running zope.interface-3.4.1/setup.py -q bdist_egg --dist-dir 
/tmp/easy_install-wHIZ1P/zope.interface-3.4.1/egg-dist-tmp-xJAIQI
Traceback (most recent call last):
  File "/usr/bin/easy_install", line 8, in <module>
    load_entry_point('setuptools==0.6c7', 'console_scripts', 
'easy_install')()
  File 
"/usr/lib/python2.5/site-packages/setuptools/command/easy_install.py", 
line 1670, in main
    with_ei_usage(lambda:
  File 
"/usr/lib/python2.5/site-packages/setuptools/command/easy_install.py", 
line 1659, in with_ei_usage
    return f()
  File 
"/usr/lib/python2.5/site-packages/setuptools/command/easy_install.py", 
line 1674, in <lambda>
    distclass=DistributionWithoutHelpCommands, **kw
  File "/usr/lib/python2.5/distutils/core.py", line 151, in setup
    dist.run_commands()
  File "/usr/lib/python2.5/distutils/dist.py", line 974, in run_commands
    self.run_command(cmd)
  File "/usr/lib/python2.5/distutils/dist.py", line 994, in run_command
    cmd_obj.run()
  File 
"/usr/lib/python2.5/site-packages/setuptools/command/easy_install.py", 
line 211, in run
    self.easy_install(spec, not self.no_deps)
  File 
"/usr/lib/python2.5/site-packages/setuptools/command/easy_install.py", 
line 446, in easy_install
    return self.install_item(spec, dist.location, tmpdir, deps)
  File 
"/usr/lib/python2.5/site-packages/setuptools/command/easy_install.py", 
line 476, in install_item
    self.process_distribution(spec, dists[0], deps, "Using")
  File 
"/usr/lib/python2.5/site-packages/setuptools/command/easy_install.py", 
line 519, in process_distribution
    [requirement], self.local_index, self.easy_install
  File "/usr/lib/python2.5/site-packages/pkg_resources.py", line 522, in 
resolve
    dist = best[req.key] = env.best_match(req, self, installer)
  File "/usr/lib/python2.5/site-packages/pkg_resources.py", line 758, in 
best_match
    return self.obtain(req, installer) # try and download/install
  File "/usr/lib/python2.5/site-packages/pkg_resources.py", line 770, in 
obtain
    return installer(requirement)
  File 
"/usr/lib/python2.5/site-packages/setuptools/command/easy_install.py", 
line 446, in easy_install
    return self.install_item(spec, dist.location, tmpdir, deps)
  File 
"/usr/lib/python2.5/site-packages/setuptools/command/easy_install.py", 
line 471, in install_item
    dists = self.install_eggs(spec, download, tmpdir)
  File 
"/usr/lib/python2.5/site-packages/setuptools/command/easy_install.py", 
line 655, in install_eggs
    return self.build_and_install(setup_script, setup_base)
  File 
"/usr/lib/python2.5/site-packages/setuptools/command/easy_install.py", 
line 930, in build_and_install
    self.run_setup(setup_script, setup_base, args)
  File 
"/usr/lib/python2.5/site-packages/setuptools/command/easy_install.py", 
line 919, in run_setup
    run_setup(setup_script, args)
  File "/usr/lib/python2.5/site-packages/setuptools/sandbox.py", line 
27, in run_setup
    lambda: execfile(
  File "/usr/lib/python2.5/site-packages/setuptools/sandbox.py", line 
63, in run
    return func()
  File "/usr/lib/python2.5/site-packages/setuptools/sandbox.py", line 
29, in <lambda>
    {'__file__':setup_script, '__name__':'__main__'}
  File "setup.py", line 85, in <module>
  File "/usr/lib/python2.5/distutils/core.py", line 151, in setup
    dist.run_commands()
  File "/usr/lib/python2.5/distutils/dist.py", line 974, in run_commands
    self.run_command(cmd)
  File "/usr/lib/python2.5/distutils/dist.py", line 994, in run_command
    cmd_obj.run()
  File 
"/usr/lib/python2.5/site-packages/setuptools/command/bdist_egg.py", line 
174, in run
    cmd = self.call_command('install_lib', warn_dir=0)
  File 
"/usr/lib/python2.5/site-packages/setuptools/command/bdist_egg.py", line 
161, in call_command
    self.run_command(cmdname)
  File "/usr/lib/python2.5/distutils/cmd.py", line 333, in run_command
    self.distribution.run_command(command)
  File "/usr/lib/python2.5/distutils/dist.py", line 994, in run_command
    cmd_obj.run()
  File 
"/usr/lib/python2.5/site-packages/setuptools/command/install_lib.py", 
line 20, in run
    self.build()
  File "/usr/lib/python2.5/distutils/command/install_lib.py", line 112, 
in build
    self.run_command('build_ext')
  File "/usr/lib/python2.5/distutils/cmd.py", line 333, in run_command
    self.distribution.run_command(command)
  File "/usr/lib/python2.5/distutils/dist.py", line 994, in run_command
    cmd_obj.run()
  File 
"/usr/lib/python2.5/site-packages/setuptools/command/build_ext.py", line 
46, in run
    _build_ext.run(self)
  File "/usr/lib/python2.5/distutils/command/build_ext.py", line 290, in run
    self.build_extensions()
  File "/usr/lib/python2.5/site-packages/Pyrex/Distutils/build_ext.py", 
line 82, in build_extensions
    self.build_extension(ext)
  File 
"/usr/lib/python2.5/site-packages/setuptools/command/build_ext.py", line 
175, in build_extension
    _build_ext.build_extension(self,ext)
  File "/usr/lib/python2.5/distutils/command/build_ext.py", line 453, in 
build_extension
    sources = self.swig_sources(sources, ext)
  File 
"/usr/lib/python2.5/site-packages/setuptools/command/build_ext.py", line 
77, in swig_sources
    sources = _build_ext.swig_sources(self, sources) or sources
TypeError: swig_sources() takes exactly 3 arguments (2 given)


> Thanks
>
>
>
> Brian
>
> On Tue, Jun 10, 2008 at 12:31 PM, Johann Cohen-Tanugi
> <cohen@slac.stanford.edu> wrote:
>   
>> note that I have a zope installation seemingly :
>> [root@jarrett ~]# rpm -qa | grep zope
>> python-zope-interface-3.0.1-8.fc8
>> [root@jarrett ~]# rpm --erase python-zope-interface-3.0.1-8.fc8
>> erreur: Dépendances requises:
>>       python-zope-interface est nécessaire pour (déjà installé)
>> python-twisted-core-2.5.0-2.fc8.i386
>>
>> Johann
>>
>> Brian Granger wrote:
>>     
>>> This issue is in the building of zope.interface, which we have never
>>> had any problems with.  Can you just try the following
>>>
>>> easy_install zope.interface
>>>
>>>
>>>
>>> On Tue, Jun 10, 2008 at 12:02 PM, Johann Cohen-Tanugi
>>> <cohen@slac.stanford.edu> wrote:
>>>
>>>       
>>>> hi there,
>>>> after the modif to setupbase of my earlier post, I get:
>>>> [cohen@jarrett ipython]$ python setup.py build
>>>>
>>>> ============================================================================
>>>> BUILDING IPYTHON
>>>> python: 2.5.1 (r251:54863, Oct 30 2007, 13:54:11) [GCC
>>>> 4.1.2 20070925 (Red Hat 4.1.2-33)]
>>>> platform: linux2
>>>>
>>>> OPTIONAL DEPENDENCIES
>>>> Zope.Interface: yes
>>>> Twisted: 2.5.0
>>>> Foolscap: Not found (required for parallel computing
>>>> capabilities)
>>>> OpenSSL: 0.6
>>>> sphinx: Not found (required for building documentation)
>>>> pygments: Not found (required for syntax highlighting
>>>> documentation)
>>>> nose: 0.10.0
>>>> pexpect: 2.3
>>>> running build
>>>> running build_py
>>>> package init file 'IPython/config/tests/__init__.py' not found (or not a
>>>> regular file)
>>>> package init file 'IPython/UserConfig/__init__.py' not found (or not a
>>>> regular file)
>>>> package init file 'IPython/config/tests/__init__.py' not found (or not a
>>>> regular file)
>>>> package init file 'IPython/UserConfig/__init__.py' not found (or not a
>>>> regular file)
>>>> running build_scripts
>>>>
>>>> So the first thing I want to try then is to get Foolscap.... but:
>>>> [root@jarrett ~]# easy_install Foolscap
>>>> Searching for Foolscap
>>>> Reading http://pypi.python.org/simple/Foolscap/
>>>> Couldn't find index page for 'Foolscap' (maybe misspelled?)
>>>> Scanning index of all packages (this may take a while)
>>>> Reading http://pypi.python.org/simple/
>>>> Reading http://pypi.python.org/simple/foolscap/
>>>> Reading http://foolscap.lothar.com/
>>>> Reading http://foolscap.lothar.com/trac
>>>> Best match: foolscap 0.2.8
>>>> Downloading http://foolscap.lothar.com/releases/foolscap-0.2.8.tar.gz
>>>> Processing foolscap-0.2.8.tar.gz
>>>> Running foolscap-0.2.8/setup.py -q bdist_egg --dist-dir
>>>> /tmp/easy_install-QwrLUv/foolscap-0.2.8/egg-dist-tmp-ulrUg8
>>>> zip_safe flag not set; analyzing archive contents...
>>>> Adding foolscap 0.2.8 to easy-install.pth file
>>>> Installing flogtool script to /usr/bin
>>>>
>>>> Installed /usr/lib/python2.5/site-packages/foolscap-0.2.8-py2.5.egg
>>>> Processing dependencies for Foolscap
>>>> Searching for twisted>=2.4.0
>>>> Reading http://pypi.python.org/simple/twisted/
>>>> Reading http://pypi.python.org/simple/Twisted/
>>>> Reading http://twistedmatrix.com/
>>>> Reading http://www.twistedmatrix.com
>>>> Reading http://twistedmatrix.com/products/download
>>>> Reading http://twistedmatrix.com/projects/core/
>>>> Best match: Twisted 8.1.0
>>>> Downloading
>>>>
>>>> http://tmrc.mit.edu/mirror/twisted/Twisted/8.1/Twisted-8.1.0.tar.bz2#md5=a575f29ead4cc02c54e9061d0e6ac7c3
>>>> Processing Twisted-8.1.0.tar.bz2
>>>> Running Twisted-8.1.0/setup.py -q bdist_egg --dist-dir
>>>> /tmp/easy_install-4PSY8a/Twisted-8.1.0/egg-dist-tmp-RYAHKu
>>>> twisted/protocols/_c_urlarg.c: In function 'unquote':
>>>> twisted/protocols/_c_urlarg.c:65: attention : pointer targets in passing
>>>> argument 2 of 'PycStringIO->cwrite' differ in signedness
>>>> twisted/protocols/_c_urlarg.c:75: attention : pointer targets in passing
>>>> argument 2 of 'PycStringIO->cwrite' differ in signedness
>>>> twisted/protocols/_c_urlarg.c:83: attention : pointer targets in passing
>>>> argument 2 of 'PycStringIO->cwrite' differ in signedness
>>>> twisted/protocols/_c_urlarg.c:85: attention : pointer targets in passing
>>>> argument 2 of 'PycStringIO->cwrite' differ in signedness
>>>> twisted/protocols/_c_urlarg.c:93: attention : pointer targets in passing
>>>> argument 2 of 'PycStringIO->cwrite' differ in signedness
>>>> twisted/protocols/_c_urlarg.c:96: attention : pointer targets in passing
>>>> argument 2 of 'PycStringIO->cwrite' differ in signedness
>>>> twisted/protocols/_c_urlarg.c:97: attention : pointer targets in passing
>>>> argument 2 of 'PycStringIO->cwrite' differ in signedness
>>>> twisted/python/_epoll.c: In function
>>>> '__pyx_f_6_epoll_5epoll___dealloc__':
>>>> twisted/python/_epoll.c:168: attention : label '__pyx_L1' defined but
>>>> not used
>>>> twisted/python/_epoll.c: In function '__pyx_f_6_epoll_5epoll_wait':
>>>> twisted/python/_epoll.c:432: attention : label '__pyx_L7' defined but
>>>> not used
>>>> twisted/python/_epoll.c:430: attention : label '__pyx_L6' defined but
>>>> not used
>>>> twisted/python/_epoll.c: In function '__pyx_tp_new_6_epoll_epoll':
>>>> twisted/python/_epoll.c:508: attention : unused variable 'p'
>>>> twisted/python/_epoll.c: In function '__pyx_tp_dealloc_6_epoll_epoll':
>>>> twisted/python/_epoll.c:513: attention : unused variable 'p'
>>>> twisted/python/_epoll.c: In function '__pyx_tp_traverse_6_epoll_epoll':
>>>> twisted/python/_epoll.c:528: attention : unused variable 'p'
>>>> twisted/python/_epoll.c:527: attention : unused variable 'e'
>>>> twisted/python/_epoll.c: In function '__pyx_tp_clear_6_epoll_epoll':
>>>> twisted/python/_epoll.c:533: attention : unused variable 'p'
>>>> twisted/python/_epoll.c: Hors de toute fonction :
>>>> twisted/python/_epoll.c:32: attention : '__Pyx_UnpackItem' declared
>>>> 'static' but never defined
>>>> twisted/python/_epoll.c:33: attention : '__Pyx_EndUnpack' declared
>>>> 'static' but never defined
>>>> twisted/python/_epoll.c:34: attention : '__Pyx_PrintItem' declared
>>>> 'static' but never defined
>>>> twisted/python/_epoll.c:35: attention : '__Pyx_PrintNewline' declared
>>>> 'static' but never defined
>>>> twisted/python/_epoll.c:37: attention : '__Pyx_ReRaise' declared
>>>> 'static' but never defined
>>>> twisted/python/_epoll.c:38: attention : '__Pyx_Import' declared 'static'
>>>> but never defined
>>>> twisted/python/_epoll.c:39: attention : '__Pyx_GetExcValue' declared
>>>> 'static' but never defined
>>>> twisted/python/_epoll.c:40: attention : '__Pyx_ArgTypeTest' declared
>>>> 'static' but never defined
>>>> twisted/python/_epoll.c:41: attention : '__Pyx_TypeTest' declared
>>>> 'static' but never defined
>>>> twisted/python/_epoll.c:42: attention : '__Pyx_GetStarArgs' declared
>>>> 'static' but never defined
>>>> twisted/python/_epoll.c:43: attention : '__Pyx_WriteUnraisable' declared
>>>> 'static' but never defined
>>>> twisted/python/_epoll.c:45: attention : '__Pyx_ImportType' declared
>>>> 'static' but never defined
>>>> twisted/python/_epoll.c:46: attention : '__Pyx_SetVtable' declared
>>>> 'static' but never defined
>>>> twisted/python/_epoll.c:47: attention : '__Pyx_GetVtable' declared
>>>> 'static' but never defined
>>>> twisted/python/_epoll.c:48: attention : '__Pyx_CreateClass' declared
>>>> 'static' but never defined
>>>> twisted/python/_epoll.c:50: attention : '__Pyx_InitStrings' declared
>>>> 'static' but never defined
>>>> twisted/python/_epoll.c:51: attention : '__Pyx_InitCApi' declared
>>>> 'static' but never defined
>>>> twisted/python/_epoll.c:52: attention : '__Pyx_ImportModuleCApi'
>>>> declared 'static' but never defined
>>>> Adding Twisted 8.1.0 to easy-install.pth file
>>>> Installing mailmail script to /usr/bin
>>>> Installing cftp script to /usr/bin
>>>> Installing tkconch script to /usr/bin
>>>> Installing im script to /usr/bin
>>>> Installing pyhtmlizer script to /usr/bin
>>>> Installing lore script to /usr/bin
>>>> Installing tapconvert script to /usr/bin
>>>> Installing tap2deb script to /usr/bin
>>>> Installing ckeygen script to /usr/bin
>>>> Installing t-im script to /usr/bin
>>>> Installing twistd script to /usr/bin
>>>> Installing trial script to /usr/bin
>>>> Installing tap2rpm script to /usr/bin
>>>> Installing bookify script to /usr/bin
>>>> Installing mktap script to /usr/bin
>>>> Installing manhole script to /usr/bin
>>>> Installing conch script to /usr/bin
>>>>
>>>> Installed
>>>> /usr/lib/python2.5/site-packages/Twisted-8.1.0-py2.5-linux-i686.egg
>>>> Searching for zope.interface
>>>> Reading http://pypi.python.org/simple/zope.interface/
>>>> Reading http://zope.org/Wikis/Interfaces/FrontPage
>>>> Best match: zope.interface 3.4.1
>>>> Downloading
>>>>
>>>> http://pypi.python.org/packages/source/z/zope.interface/zope.interface-3.4.1.tar.gz#md5=b085f4a774adab688e037ad32fbbf08e
>>>> Processing zope.interface-3.4.1.tar.gz
>>>> Running zope.interface-3.4.1/setup.py -q bdist_egg --dist-dir
>>>> /tmp/easy_install-15j3pH/zope.interface-3.4.1/egg-dist-tmp--AQrWm
>>>> Traceback (most recent call last):
>>>> File "/usr/bin/easy_install", line 8, in <module>
>>>> load_entry_point('setuptools==0.6c7', 'console_scripts',
>>>> 'easy_install')()
>>>> File
>>>> "/usr/lib/python2.5/site-packages/setuptools/command/easy_install.py",
>>>> line 1670, in main
>>>> with_ei_usage(lambda:
>>>> File
>>>> "/usr/lib/python2.5/site-packages/setuptools/command/easy_install.py",
>>>> line 1659, in with_ei_usage
>>>> return f()
>>>> File
>>>> "/usr/lib/python2.5/site-packages/setuptools/command/easy_install.py",
>>>> line 1674, in <lambda>
>>>> distclass=DistributionWithoutHelpCommands, **kw
>>>> File "/usr/lib/python2.5/distutils/core.py", line 151, in setup
>>>> dist.run_commands()
>>>> File "/usr/lib/python2.5/distutils/dist.py", line 974, in run_commands
>>>> self.run_command(cmd)
>>>> File "/usr/lib/python2.5/distutils/dist.py", line 994, in run_command
>>>> cmd_obj.run()
>>>> File
>>>> "/usr/lib/python2.5/site-packages/setuptools/command/easy_install.py",
>>>> line 211, in run
>>>> self.easy_install(spec, not self.no_deps)
>>>> File
>>>> "/usr/lib/python2.5/site-packages/setuptools/command/easy_install.py",
>>>> line 446, in easy_install
>>>> return self.install_item(spec, dist.location, tmpdir, deps)
>>>> File
>>>> "/usr/lib/python2.5/site-packages/setuptools/command/easy_install.py",
>>>> line 473, in install_item
>>>> self.process_distribution(spec, dist, deps)
>>>> File
>>>> "/usr/lib/python2.5/site-packages/setuptools/command/easy_install.py",
>>>> line 519, in process_distribution
>>>> [requirement], self.local_index, self.easy_install
>>>> File "/usr/lib/python2.5/site-packages/pkg_resources.py", line 522, in
>>>> resolve
>>>> dist = best[req.key] = env.best_match(req, self, installer)
>>>> File "/usr/lib/python2.5/site-packages/pkg_resources.py", line 758, in
>>>> best_match
>>>> return self.obtain(req, installer) # try and download/install
>>>> File "/usr/lib/python2.5/site-packages/pkg_resources.py", line 770, in
>>>> obtain
>>>> return installer(requirement)
>>>> File
>>>> "/usr/lib/python2.5/site-packages/setuptools/command/easy_install.py",
>>>> line 446, in easy_install
>>>> return self.install_item(spec, dist.location, tmpdir, deps)
>>>> File
>>>> "/usr/lib/python2.5/site-packages/setuptools/command/easy_install.py",
>>>> line 471, in install_item
>>>> dists = self.install_eggs(spec, download, tmpdir)
>>>> File
>>>> "/usr/lib/python2.5/site-packages/setuptools/command/easy_install.py",
>>>> line 655, in install_eggs
>>>> return self.build_and_install(setup_script, setup_base)
>>>> File
>>>> "/usr/lib/python2.5/site-packages/setuptools/command/easy_install.py",
>>>> line 930, in build_and_install
>>>> self.run_setup(setup_script, setup_base, args)
>>>> File
>>>> "/usr/lib/python2.5/site-packages/setuptools/command/easy_install.py",
>>>> line 919, in run_setup
>>>> run_setup(setup_script, args)
>>>> File "/usr/lib/python2.5/site-packages/setuptools/sandbox.py", line 27,
>>>> in run_setup
>>>> lambda: execfile(
>>>> File "/usr/lib/python2.5/site-packages/setuptools/sandbox.py", line 63,
>>>> in run
>>>> return func()
>>>> File "/usr/lib/python2.5/site-packages/setuptools/sandbox.py", line 29,
>>>> in <lambda>
>>>> {'__file__':setup_script, '__name__':'__main__'}
>>>> File "setup.py", line 85, in <module>
>>>> File "/usr/lib/python2.5/distutils/core.py", line 151, in setup
>>>> dist.run_commands()
>>>> File "/usr/lib/python2.5/distutils/dist.py", line 974, in run_commands
>>>> self.run_command(cmd)
>>>> File "/usr/lib/python2.5/distutils/dist.py", line 994, in run_command
>>>> cmd_obj.run()
>>>> File "/usr/lib/python2.5/site-packages/setuptools/command/bdist_egg.py",
>>>> line 174, in run
>>>> cmd = self.call_command('install_lib', warn_dir=0)
>>>> File "/usr/lib/python2.5/site-packages/setuptools/command/bdist_egg.py",
>>>> line 161, in call_command
>>>> self.run_command(cmdname)
>>>> File "/usr/lib/python2.5/distutils/cmd.py", line 333, in run_command
>>>> self.distribution.run_command(command)
>>>> File "/usr/lib/python2.5/distutils/dist.py", line 994, in run_command
>>>> cmd_obj.run()
>>>> File
>>>> "/usr/lib/python2.5/site-packages/setuptools/command/install_lib.py",
>>>> line 20, in run
>>>> self.build()
>>>> File "/usr/lib/python2.5/distutils/command/install_lib.py", line 112, in
>>>> build
>>>> self.run_command('build_ext')
>>>> File "/usr/lib/python2.5/distutils/cmd.py", line 333, in run_command
>>>> self.distribution.run_command(command)
>>>> File "/usr/lib/python2.5/distutils/dist.py", line 994, in run_command
>>>> cmd_obj.run()
>>>> File "/usr/lib/python2.5/site-packages/setuptools/command/build_ext.py",
>>>> line 46, in run
>>>> _build_ext.run(self)
>>>> File "/usr/lib/python2.5/distutils/command/build_ext.py", line 290, in
>>>> run
>>>> self.build_extensions()
>>>> File "/usr/lib/python2.5/site-packages/Pyrex/Distutils/build_ext.py",
>>>> line 82, in build_extensions
>>>> self.build_extension(ext)
>>>> File "/usr/lib/python2.5/site-packages/setuptools/command/build_ext.py",
>>>> line 175, in build_extension
>>>> _build_ext.build_extension(self,ext)
>>>> File "/usr/lib/python2.5/distutils/command/build_ext.py", line 453, in
>>>> build_extension
>>>> sources = self.swig_sources(sources, ext)
>>>> File "/usr/lib/python2.5/site-packages/setuptools/command/build_ext.py",
>>>> line 77, in swig_sources
>>>> sources = _build_ext.swig_sources(self, sources) or sources
>>>> TypeError: swig_sources() takes exactly 3 arguments (2 given)
>>>>
>>>>
>>>> and that I do not know what to do with it :) Her is what I have for swig:
>>>> [root@jarrett ~]# rpm -qa | grep -i swig
>>>> swig-1.3.33-1.fc8
>>>> [root@jarrett ~]#
>>>>
>>>> _______________________________________________
>>>> IPython-dev mailing list
>>>> IPython-dev@scipy.org
>>>> http://lists.ipython.scipy.org/mailman/listinfo/ipython-dev
>>>>
>>>>
>>>>         


More information about the IPython-dev mailing list