[IPython-dev] Critical: For now IPython requires Python 2.5 - we need to fix this

Brian Granger ellisonbg.net@gmail....
Thu Jun 12 15:11:29 CDT 2008


Hi,

Now that all of the stuff from ipython1 has moved into IPython,
IPython has new fancy parallel computing capabilities.....and..... a
dependency on Python 2.5.

Here is the story.  In IPython.kernel there is a likely lots of code
that requires python 2.4, and a little that requires 2.5.  At this
point, it is probably too late to get rid of the 2.4 specific stuff,
but we still have to figure out what to do about 2.5 specific syntax
and features.

The main things are our usage of the with statement.  Currently
building IPython with <2.5 gives a syntax error because of this.  We
clearly need to fix this as IPython definitely needs to run under 2.4.
 But, how do we want to handle these things?  Requires 2.4 and make
2.5 features optional?  Thoughts?

Brian


More information about the IPython-dev mailing list