[IPython-dev] Critical: For now IPython requires Python 2.5 - we need to fix this

Robert Kern robert.kern@gmail....
Thu Jun 12 15:34:43 CDT 2008


Fernando Perez wrote:

> I think we'll have to be OK with 2.4 as a dependency for versions >=
> 0.9, but 2.5 is definitely a little harsh.  I *really* want those cool
> context managers in there, the idea is too cool not to put it  in.

You can define the context managers all you like as long as you don't use them 
in the library code itself. As far as I can tell, the only place you actually 
use a with statement is in the demo code at the bottom of context.py which, as 
noted in the comments, really ought to be moved into a real test suite.

> But we need them to be optional.  The trick is to exclude them from
> the build process if the  setup.py file is processed with python2.4,
> since they simply won't compile at all (the with statement is a syntax
> error).

I have seen this give warnings, but I don't think it stops the build, usually.

-- 
Robert Kern

"I have come to believe that the whole world is an enigma, a harmless enigma
  that is made terrible by our own mad attempt to interpret it as though it had
  an underlying truth."
   -- Umberto Eco



More information about the IPython-dev mailing list