[IPython-dev] Critical: For now IPython requires Python 2.5 - we need to fix this

Brian Granger ellisonbg.net@gmail....
Thu Jun 12 15:48:27 CDT 2008


>> You can define the context managers all you like as long as you don't use them
>> in the library code itself. As far as I can tell, the only place you actually
>> use a with statement is in the demo code at the bottom of context.py which, as
>> noted in the comments, really ought to be moved into a real test suite.

This is true, I don't think we actually need to use the with statement
at this point in library code.  We just need to be able to define the
context managers.

> Since I'll be working on the tests, I'll take care of this.

Thanks.

Brian

> Cheers,
>
> f
> _______________________________________________
> IPython-dev mailing list
> IPython-dev@scipy.org
> http://lists.ipython.scipy.org/mailman/listinfo/ipython-dev
>


More information about the IPython-dev mailing list