[IPython-dev] Bzr install under vista + bzr olive-gtk

Alexander Belchenko bialix@ukr....
Tue Mar 25 15:07:47 CDT 2008


Laurent Dufréchou пишет:
> Hi all,
> Where can I put some info on how to install bzr under Vista?

It will be nice if you put the copy of your instruction to http://bazaar-vcs.org.
It's a wiki in the end.

There is already instructions how to install it:
http://bazaar-vcs.org/WindowsInstall

Can you tell me is this instructions is wrong or not good enough?

> I've installed it with the .exe that is a big error and nobody must do that.

It's shame for me personally to hear this.

> So I would like to warn newcomers how to set up bzr + bzr gui tools without
> too much pain...

QBzr GUI is compatible with bzr.exe. Of course, it's not the GTK one.

> I had installed bzr via the .exe install that is completely uncompatible
> with the olive-gtk gui (!)

IMO, it's not true. Here is package of bzr-gtk compatible with bzr.exe:
http://d5190871.u44.websitesource.net/bzr/

There is bzr-gtk-0.93.0 release only, but I don't follow bzr-gtk development,
so I'm not sure what's latest release is.

> I had to deinstall bzr and install the bzr python installer,(setup.py
> install as administrator).
> Now bzr viz and all other things works.
> 
> Here is an interesting link:
> http://bazaar-vcs.org/MariusKruger#head-e234ddc518938afb140793d47320a2bee0b6
> c8aa
> (a bit old, but you can easily find newer packages)
> 
> and
> http://bazaar-vcs.org/Download

> (DO not use the standalone installer or will not have a working plugin
> directory!)

I don't understand this warning. Can you explain it a bit more?



More information about the IPython-dev mailing list