[IPython-dev] Twisted 8...

Barry Wark barrywark@gmail....
Mon Mar 31 20:18:35 CDT 2008


Being installable via easy_install is a huge win (really a
requirement) on OS X 10.5. Leopard comes with a system Twisted 2.4 and
installing a newer version (such as the 2.5 required by ipython1)
requires mucking with the PYTHONPATH (not a mac user-friendly task).
Even worse, PYTHONPATH changes are not propagated via sudo (for
obvious reasons), so running code that requires twisted 2.5 as root is
impossible, even with the PYTHONPATH modification. Installation via
easy_install fixes these issues (the easy_install'd  Twisted is placed
before the system Twisted on the sys.path by setuptools). With
setuptools/easy_install support, it's possible to automate deployment
of pre-compiled eggs.

There's currently a branch of Twisted 2.5 that is installable via
setuptools/easy_install, but the official release isn't.

So, making Twisted and ipython1 a reality of OS X will require
setuptools/easy_install support. So, +1 from OS X land.

Barry


On Mon, Mar 31, 2008 at 5:15 PM, Fernando Perez <fperez.net@gmail.com> wrote:
> On Fri, Mar 28, 2008 at 1:00 PM, Brian Granger <ellisonbg.net@gmail.com> wrote:
>
>
> >  I am plannig to get IPython1 working with Twisted 8.0 soon.  As you
>  >  mention, there should only be a few things we have to do.  How do
>  >  people feel about requiring the new version of Twisted?  It is a
>  >  significant release, and Twisted 2.5.0 had been out for a very long
>  >  time.
>
>  Just curious: what *benefits* do we obtain from using twisted 8.0?
>  It's nice that today, all of ipython1's depenedencies are satisfied
>  out of the box on current linux distros.  But even the
>  not-yet-released ubuntu has twisted 8, they are still on 2.5:
>
>  http://packages.ubuntu.com/hardy/python-twisted-core
>
>  I'm not fundamentally opposed to requiring 8.0 if we actually need it,
>  but otherwise I'd prefer to find a way (if possible, I haven't looked
>  at the code) to work with both 2.5 and 8.0. I hope the twisted devs
>  didn't make so many backwards incompatible changes as to make that
>  impossible...
>
>  Cheers,
>
>
>
>  f
>  _______________________________________________
>  IPython-dev mailing list
>  IPython-dev@scipy.org
>  http://lists.ipython.scipy.org/mailman/listinfo/ipython-dev
>


More information about the IPython-dev mailing list