[IPython-dev] ipython-0.9.0.bzr.r1016-py2.5.win32-setup.exe?? [was: Re: Win32 IPython1?]

Alex Brown Alexander_Brown@uml....
Thu Sep 4 16:37:55 CDT 2008


Dave Peterson wrote:
> I was under the impression that Windows users could use the MinGW 
> compiler to build things compatible with the MSVC we used to build 
> EPD.   That's one of the reasons we ship it.
>
You are almost certainly correct - I did not have time to deal with this 
in detail and found that VS03 worked well enough.  MinGW would be better.
> I don't know anything about DeinoMPI, but it seems to be the MPI libs 
> that mpi4py will link against, right?  If so, you should be able to 
> build mpi4py against a MSVC version of these by making sure to set 
> your distutils.cfg or pydistutils.cfg to define the compiler to use to 
> be mingw.   There are numerous threads on doing this on various 
> mailing lists, plus it is covered in the distutils docs.
Hm - you are probably right - DeinoMPI is the culprit, not EPD.  The 
build error was from mpi4py of course.  I will look into the cfgs.
> BTW, in the future, an EPD install will contain an appropriately setup 
> distutils.cfg to default the compiler to the mingw we ship in EPD.   
> IIRC, it is already in the current beta -- EPD with Py2.5 v4.0.30001 
> Beta 1.
>
>
> -- Dave
>
Great - thanks again.  I'm not inexperienced with software make/build 
tools in other contexts but Python internals and distribution tools are 
still somewhat new to me;  I appreciate everyone's interest.

- Alex

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.ipython.scipy.org/pipermail/ipython-dev/attachments/20080904/34526106/attachment.html 


More information about the IPython-dev mailing list