[IPython-dev] ipython0.9 and python2.4

Fernando Perez fperez.net@gmail....
Sun Sep 14 16:11:48 CDT 2008


On Sun, Sep 14, 2008 at 7:26 AM, Nils Wagner
<nwagner@iam.uni-stuttgart.de> wrote:
> Hi all,
>
> I just installed ipython from source.
> I found an incompatibility wrt python2.4

This is turning into a minor nightmare.  There were LOTS more 2.5
things in there:

import _ast
import uuid

in the frontend code...

Please, from now on: let's always run the test suite with 2.4 and 2.5
always.  This is not fun.

Cheers,

f


More information about the IPython-dev mailing list