[IPython-dev] ipython0.9 and python2.4

Fernando Perez fperez.net@gmail....
Sun Sep 14 16:21:13 CDT 2008


On Sun, Sep 14, 2008 at 2:17 PM, Gael Varoquaux
<gael.varoquaux@normalesup.org> wrote:
> On Sun, Sep 14, 2008 at 02:11:48PM -0700, Fernando Perez wrote:
>> This is turning into a minor nightmare.  There were LOTS more 2.5
>> things in there:
>
>> import _ast
>> import uuid
>
>> in the frontend code...
>
> Well, let us just say that the frontend code is 2.5 only. Now how do we
> enforce this on the packaging level? I don't know.

I'd much rather keep 2.4 compatibility everywhere.  Making a project
with pieces that are version dependent is a recipe for disaster: the
packaging gets very brittle and the maintenance burden gets much, much
worse.

Until we find a compelling reason why we MUST use 2.5, we should make
our code work with 2.4.  There's still a lot of 2.4-only installations
out there, I assure you.  This week Brian, Min and I need to validate
all of ipython 0.9 on one such set of beasts, for example.  It's going
to be great...

Cheers,

f


More information about the IPython-dev mailing list