[IPython-dev] ipython0.9 and python2.4

Brian Granger ellisonbg.net@gmail....
Sun Sep 14 16:22:16 CDT 2008


>> Well, let us just say that the frontend code is 2.5 only. Now how do we
>> enforce this on the packaging level? I don't know.
>
> I'd much rather keep 2.4 compatibility everywhere.  Making a project
> with pieces that are version dependent is a recipe for disaster: the
> packaging gets very brittle and the maintenance burden gets much, much
> worse.

+1


More information about the IPython-dev mailing list