[IPython-dev] ipython0.9 and python2.4

Brian Granger ellisonbg.net@gmail....
Sun Sep 14 16:29:12 CDT 2008


I have time to work on this now.  Push your trunk-dev and I will take
over.  I will keep the list posted on my progress.

Brian

On Sun, Sep 14, 2008 at 2:25 PM, Fernando Perez <fperez.net@gmail.com> wrote:
> On Sun, Sep 14, 2008 at 2:11 PM, Fernando Perez <fperez.net@gmail.com> wrote:
>> On Sun, Sep 14, 2008 at 7:26 AM, Nils Wagner
>> <nwagner@iam.uni-stuttgart.de> wrote:
>>> Hi all,
>>>
>>> I just installed ipython from source.
>>> I found an incompatibility wrt python2.4
>>
>> This is turning into a minor nightmare.  There were LOTS more 2.5
>> things in there:
>
> OK, I give up for now.  I'm going to take a break and see where I can
> get later, but I may not be able to spend more time on this today.
> The problem is that I deactivated the config stuff altogether to avoid
> the with statement, thinking it wasn't yet used everywhere.  Well, it
> is:
>
> ======================================================================
> ERROR: Failure: exceptions.ImportError(No module named config.api)
> ----------------------------------------------------------------------
> Traceback (most recent call last):
>  File "/var/lib/python-support/python2.4/nose/loader.py", line 360,
> in loadTestsFromName
>    module = self.importer.importFromPath(
>  File "/var/lib/python-support/python2.4/nose/importer.py", line 39,
> in importFromPath
>    return self.importFromDir(dir_path, fqname)
>  File "/var/lib/python-support/python2.4/nose/importer.py", line 84,
> in importFromDir
>    mod = load_module(part_fqname, fh, filename, desc)
>  File "/home/fpa/usr/local/lib/python2.4/site-packages/ipython-0.9.1-py2.4.egg/IPython/kernel/config/__init__.py",
> line 21, in ?
>    from IPython.config.api import ConfigObjManager
> ImportError: No module named config.api
>
>
> We can't run the kernel code on 2.4 at all in this manner...
>
> I'm thinking of just pushing my current trunk-dev up to lp and see if
> someone can pitch in quickly in case I can't continue.  I've fixed a
> lot of the failures, but now it seems that deactivating the config
> stuff isn't viable: we need to make it 2.4-compliant, like it or not.
> Which means rewriting some of its with-using code to not use 'with' at
> all.
>
> Cheers,
>
> f
> _______________________________________________
> IPython-dev mailing list
> IPython-dev@scipy.org
> http://lists.ipython.scipy.org/mailman/listinfo/ipython-dev
>


More information about the IPython-dev mailing list