[IPython-dev] Pylab support: How about dynamic backend selection?

Gael Varoquaux gael.varoquaux@normalesup....
Wed Sep 24 07:23:39 CDT 2008


On Wed, Sep 24, 2008 at 02:11:11PM +0200, Hans Meine wrote:
> right now, IPython has special thread support for different GUI
> backends, and
> special support for MPL/pylab.  AFAIK, when I specify -pylab on the
> cmdline,
> ipython will choose the "right" GUI toolkit depending on my
> matplotlibrc
> backend setting.  However, I sometimes need Qt4 and sometimes WX
> support,
> which are both supported by MPL, but the -pylab overwrites the
> threading
> switch.

> My suggestion is to let the -pylab switch gracefully handle -foothread
> switches by internally calling matplotlib.use(...) to let MPL use the
> same
> GUI toolkit that has been specified on the cmdline.

In the latest ipython, this behavior should be possible:

ipython "-pylab -wthread" should be running matplotlib with the Wx
support.


Gaël


More information about the IPython-dev mailing list