[IPython-dev] possible cpaste bug

Fernando Perez fperez.net@gmail....
Tue Aug 11 01:51:01 CDT 2009


On Mon, Aug 10, 2009 at 9:39 PM, Robert Kern<robert.kern@gmail.com> wrote:
> Are you sure that the correct text got fully pasted? I have had problems pasting
> moderate amounts of text, a couple of screenfuls, into a terminal on OS X,
> particularly with iTerm but also I think with Terminal.app. Some lines go
> missing or get repeated. The problem occurs with any program, not just IPython.

I should have pasted in the message the real input and not just the
traceback, it would have shown that indeed this seems to be, as you
suspect, a problem with the terminal itself.  I now tried it in
gnome-terminal, konsole and plain ole' xterm.  The first two both
cause the problem (in slightly different parts of the input,  but
always around the various f3* declarations),  while xterm is always
OK.

I suspect this is because xterm doesn't try to do anything fancy with
fonts (or anything else for that  matter) while g-t/konsole both use
pretty, anti-aliased fonts that take day and night to render.  The
overhead of rendering text and scrolling seems to be sufficient to
cause the  app to drop input from the paste stream somehow, in fact I
can see both 'stutter' as the pasted text accumulates.  Xterm paints
the text in ugly, old-style fonts but it does so blazingly fast, and
has no problems at all with the long input.

John, could you try using xterm on the mac as well? I think the X11
app ships with a plain old xterm, that could show a similar pattern to
what I'm seeing on linux.

Good catch, Robert, thanks.

Cheers,

f


More information about the IPython-dev mailing list