[IPython-dev] Dropping 2.4 support

Brian Granger ellisonbg.net@gmail....
Fri Aug 21 14:04:28 CDT 2009


I'm inclined to want to drop it, but I'd like to make it a reasoned
> decision.  Let's try to make a brief list of:
>
> - Specific things we gain from being 2.5-only (not the "what's new in
> 2.5" document, but which of those do *we* benefit from)
>

* Absolute imports would allow us to ship enthought.traits in externals and
avoid 1) the performance problems of namespace packages and 2) conflicting
with other installed versions of enthought.traits.

* Certain parts of twisted use the new generator features in 2.5.  Being
able to use these features of twisted would probably dramatically simplify
all of our twisted using test code.  This would be a *massive* improvement
in maintainability.

* Obviously there are all the other minor things like with and
try/except/else/finally, but these are convenience things.

* The faster we drop support for python 2.4 and 2.5, the easier moving to
py3k will be.  I am not yet proposing that we drop 2.5 support though.




>
> - Which major forms of python distribution (linux distros, defaults on
> solaris or other big unix systems, versions of osx, etc) default to
> 2.4?
>
> At least that way we'll be able to weigh the costs and benefits and
> document, if we take the step, why we do it.
>
> Cheers,
>
> f
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/ipython-dev/attachments/20090821/67275627/attachment.html 


More information about the IPython-dev mailing list