[IPython-dev] Dropping 2.4 support

Gael Varoquaux gael.varoquaux@normalesup....
Fri Aug 21 14:10:24 CDT 2009


On Fri, Aug 21, 2009 at 12:04:28PM -0700, Brian Granger wrote:
>      I'm inclined to want to drop it, but I'd like to make it a reasoned
>      decision.  Let's try to make a brief list of:

>      - Specific things we gain from being 2.5-only (not the "what's new in
>      2.5" document, but which of those do *we* benefit from)

>    * Absolute imports would allow us to ship enthought.traits in externals
>    and avoid 1) the performance problems of namespace packages and 2)
>    conflicting with other installed versions of enthought.traits.

Yes. IMHO this one is huge. I have been pushing people a lot to use
relative imports.

G.


More information about the IPython-dev mailing list