[IPython-dev] [Enthought-Dev] PySide to replace PyQt?

Robert Kern robert.kern@gmail....
Thu Aug 27 16:34:58 CDT 2009


On 2009-08-27 16:15 PM, Ville M. Vainio wrote:
> On Fri, Aug 28, 2009 at 12:01 AM, Robert Kern<robert.kern@gmail.com>  wrote:
>
>>> Don't underestimate the lure of LGPL. People can tolerate quite a bit
>>> of technical hurdles to get a more permissive license (c.f. Gnome/KDE
>>> in the past - Gnome sucked quite a bit pre-2.0, yet it was the more
>>> popular one among distributors).
>>
>> Particularly since the new license restrictions on sip are GPL-incompatible. I
>> don't see Linux distributions picking up PyQt4 4.5 anytime soon.
>
> It's already on Ubuntu and Debian (Karmic has sip 4.8.1-1, pyqt
> 4.5.2-0ubuntu1). IIRC PyQT 4.5 was already on Jaunty.
>
> Related bug (seems to be filed just a while ago):
>
> http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=543730

The license change kind of slipped in unannounced. I should amend my statement: 
"I don't see Linux distributions pick up PyQt4 4.5 knowing the license change 
anytime soon."

-- 
Robert Kern

"I have come to believe that the whole world is an enigma, a harmless enigma
  that is made terrible by our own mad attempt to interpret it as though it had
  an underlying truth."
   -- Umberto Eco



More information about the IPython-dev mailing list