[IPython-dev] [matplotlib-devel] IPython proposal: getting rid of "ipython -pylab\-wthread\etc."

Gael Varoquaux gael.varoquaux@normalesup....
Thu Jul 16 16:31:50 CDT 2009


On Thu, Jul 16, 2009 at 01:36:21PM -0700, Brian Granger wrote:
>    What versions of what GUI toolkits do we realistically need to support
>    moving forward (today and beyond)?  By this, I mean that:

>    "unsupported" = older versions of GUIs toolkits that will have to use
>    older versions of IPython.
>     "supported" = versions of GUIS that will be able to use the
>    PyOS_InputHook approach in newer releases of IPython.

For Wx, we would obviously need to support 2.8. We can toy with the idea
of not supporting 2.6, I believe. A lot of people are starting to feel
that 2.6 is depreciated.

Gaël


More information about the IPython-dev mailing list