[IPython-dev] fixing warnings in python2.6

Ondrej Certik ondrej@certik...
Mon Mar 16 22:25:39 CDT 2009


On Mon, Mar 16, 2009 at 8:21 PM, Fernando Perez <fperez.net@gmail.com> wrote:
> 2009/3/16 Ondrej Certik <ondrej@certik.cz>:
>> Hi,
>>
>> the attached patch fixes the annoying warning in python2.6:
>>
>> $ ipython
>> /var/lib/python-support/python2.6/IPython/Magic.py:38:
>> DeprecationWarning: the sets module is deprecated
>>  from sets import Set
>
> thanks, man, but it's already fixed in my branch:
>
> https://code.launchpad.net/~fdo.perez/ipython/trunk-dev/+merge/4450
>
> I'm addressing Brian's review, and should be able to merge by tomorrow, I think.

Ok, I think I can wait till tomorrow. I was only following the main branch.

How do I run the tests though if I wanted to fix something else?

Ondrej


More information about the IPython-dev mailing list