[IPython-dev] [sympy] Re: IPython.ipapi stopped working

Ondrej Certik ondrej@certik...
Wed Oct 14 14:13:43 CDT 2009


On Wed, Oct 14, 2009 at 12:06 PM, Brian Granger <ellisonbg.net@gmail.com> wrote:
> Ondrej,
>
> Yes, as Robert said, trunk is in a semi-unstable state right now.  Most
> things do work, but
> the APIs have changed.  I can help you update the sympy things to the new
> APIs, but it is
> probably a little early.
>
> Other than isympy, in what other ways does sympy use IPython?
>
> I can help you update the things in sympy.
>
> I have already created a sympy profile for ipython that does what isympy
> does:
>
> http://bazaar.launchpad.net/~ipython-dev/ipython/trunk/annotate/head%3A/IPython/config/profile/ipython_config_sympy.py
>
> Also, I have implemented the top-level embed function you requested.  If you
> don't mind going
> back to the latest release, I will try to get sympy working with the new
> stuff.

Excellent, thanks so much for the help. I will use the latest release
till then. The only reason I use the bzr trunk is because of the
IPython.embed() feature.

I think we should use the IPython's api in the correct way -- e.g. I
think just using the profile as you did. The only way we use IPython
is by trying to import it in sympy/interactive/ and set the pretty
printing in it. And then in isympy.

Ondrej


More information about the IPython-dev mailing list