[IPython-dev] GSoC applicants: patch and blog required

Fernando Perez fperez.net@gmail....
Thu Apr 15 20:21:18 CDT 2010


Hi,

On Thu, Apr 15, 2010 at 6:15 PM, Fernando Perez <fperez.net@gmail.com> wrote:
>> Hi again, this is really strange, I've done all the steps you show above but
>> there's another problem :'( ...
>> /home/muzgash/MyProjects/ipython/docs/sphinxext/docscrape.py:117:
>> UserWarning: Unknown section Options
>>   warn("Unknown section %s" % key)
>> reading sources... [ 19%] api/generated/IPython.kernel.clientconnector
>> Exception occurred:
>>   File
>> "/home/muzgash/MyProjects/ipython/docs/sphinxext/inheritance_diagram.py",
>> line 107, in _import_class_or_module
>>     "Could not import class or module '%s' specified for inheritance
>> diagram" % name)
>> ValueError: Could not import class or module
>> 'IPython.kernel.clientconnector' specified for inheritance diagram
>> The full traceback has been saved in /tmp/sphinx-err-L_nA3u.log, if you want
>> to report the issue to the developers.

I should have also added that you need to get used to debugging these
kinds of problems, as they are a common occurrence.  The error message
there says pretty much everything you need to do, as it says:

: Could not import class or module 'IPython.kernel.clientconnector'

With that, you go into ipython and try to import
IPython.kernel.clientconnector, which shows you the underlying error:

ImportError                               Traceback (most recent call last)

/home/muzgash/MyProjects/ipython/docs/<ipython console> in <module>()

/usr/lib/python2.5/site-packages/IPython/kernel/clientconnector.py in <module>()
     16 import os
     17
---> 18 from IPython.kernel.fcutil import (
     19     Tub,
     20     find_furl,

/usr/lib/python2.5/site-packages/IPython/kernel/fcutil.py in <module>()
     24 from twisted.python import log
     25
---> 26 import foolscap
     27 try:
     28     from foolscap.api import Tub, UnauthenticatedTub

ImportError: No module named foolscap

Aha, you need something called 'foolscap'.  Then a bit of searching
will tell you that the actual package name is 'python-foolscap', so
you type:

apt-get install python-foolscap

and the problem is solved.

Debugging these types of errors may look nasty, but it's a basic
survival skill wen developing code, which you must acquire.

Cheers,

f


More information about the IPython-dev mailing list