[IPython-dev] Closing in on 0.11? We need some review/feedback help

Fernando Perez fperez.net@gmail....
Wed Jan 13 11:00:15 CST 2010


Hey,

On Wed, Jan 13, 2010 at 8:56 AM, John Hunter <jdh2358@gmail.com> wrote:
>
> What minimum version of python are you targeting?  I just attempted to
> install at work on python2.4 and got

2.5 :(

if sys.version[0:3] < '2.5':
    raise ImportError('Python Version 2.5 or above is required for IPython.')

See:

https://bugs.launchpad.net/ipython/+bug/505090

Sorry, but 2.4 is getting way too long in the tooth, and for us the
only realistic way to think about 3.x compatibility is to start
ditching the older versions.  We simply don't have the manpower to
maintain a codebase from 2.4 to 3.1...

Cheers,

f


More information about the IPython-dev mailing list