[IPython-dev] Running tests

Jörgen Stenarson jorgen.stenarson@bostream...
Thu Jan 14 12:05:23 CST 2010


Fernando Perez skrev 2010-01-13 20:35:
> On Mon, Jan 11, 2010 at 1:13 PM, Jörgen Stenarson
> <jorgen.stenarson@bostream.nu>  wrote:
>>>
>> I have tried both approaches with the same result.
>
> BTW, try the new code I posted yesterday (if you're running from
> branch, just bzr pull on it).  It should be a lot better, bug me if
> not.
>
> f
>
There is something strange going on here.

I just installed the latest trunk with setup.py install

If I just use iptest then I get a bunch of tests run with a very verbose 
output i.e. one line for every test.

With iptest -q I get lots of errors and failures it seems not all 
testgroups are used.

Using the verbosity setting also generates lots of errors.

The output of iptest IPython.core looks strange:

............................................................................S...
 >>>
 >>>
 >>>
 >>>
 >>>
 >>>
 >>>
 >>>
 >>>
 >>>
 >>>
 >>>
 >>>
 >>>
 >>>
 >>>
 >>>
 >>>
 >>>
 >>>
 >>>
 >>>
 >>>
 >>>
 >>>
 >>>
 >>>
 >>>
 >>>
 >>>
 >>>
 >>>
 >>>
 >>>
 >>>
 >>>
 >>>
 >>>
 >>>
 >>> None
........ERROR: File 
`"c:\docume~1\jstenar\lokala~1\temp\tmpjbspu3.py".py` not fo
und.
.ERROR: File `"c:\docume~1\jstenar\lokala~1\temp\tmpaawkae.py".py` not 
found.
.ERROR: File `"c:\docume~1\jstenar\lokala~1\temp\tmp88arfl.py".py` not 
found.
.S.S.ERROR: File `"c:\docume~1\jstenar\lokala~1\temp\tmpjjry9e.py".py` 
not found
.
.
----------------------------------------------------------------------
Ran 99 tests in 0.454s

OK (SKIP=3)




Is it possible to run the tests without installing?

/Jörgen


More information about the IPython-dev mailing list