[IPython-dev] Updated build of trunk-dev available

Fernando Perez fperez.net@gmail....
Mon Jan 18 00:02:51 CST 2010


Hey,

On Sun, Jan 17, 2010 at 9:59 PM, Gökhan Sever <gokhansever@gmail.com> wrote:
>
> NOTE:
>
> In [3]: import IP
>
> here tab-complete doesn't work for IPython itself. Isn't it weird? Does it
> work on your system?

No, that's a known regression: the completion extensions haven't been
ported to the new API yet, so only basic completion is working right
now.  Your first contribution on this front for 0.11 would make lots
of people happy :)

> It is still the same after I installed it. The same errors and no kernel
> test run.

OK, that makes sense now, given this:

Tools and libraries NOT available at test time:
   foolscap objc twisted wx wx.aui zope.interface

Without foolscap, twisted and zope.interface, the kernel can't be tested.

If you install those and try again, the kernel tests can run.

BTW, could you paste again the current error tracebacks you're getting
so I see them exactly now?

Cheers,

f


More information about the IPython-dev mailing list