[IPython-dev] %run -d is broken in Python 2.7

vano vano@mail.mipt...
Mon Jul 12 20:26:12 CDT 2010


Subj. On attempting to run a script under (colored :-) ) debugger the
following appears (VV excerpt, full message is attached):

In [1]: %run -e -d setup.py build
---------------------------------------------------------------------------
AttributeError                            Traceback (most recent call last)

C:\Ivan\Cython-0.12.1\<ipython console> in <module>()
D:\py\lib\site-packages\ipython-0.10-py2.7.egg\IPython\iplib.pyc in ipmagic(self, arg_s)
-> 1182             return fn(magic_args)

D:\py\lib\site-packages\ipython-0.10-py2.7.egg\IPython\Magic.pyc in magic_run(self, parameter_s, runner, file_finder)
-> 1633                     checkline = deb.checkline(filename,bp)

D:\py\lib\pdb.py in checkline(self, filename, lineno)
--> 470         line = linecache.getline(filename, lineno, self.curframe.f_globals)

AttributeError: Pdb instance has no attribute 'curframe'
> d:\py\lib\pdb.py(470)checkline()
--> 470         line = linecache.getline(filename, lineno, self.curframe.f_globals)


---------------------------------------------------------------------------
After thorough investigation, it turned out a pdb issue (details are
on the link), so i filed a bug there (http://bugs.python.org/issue9230) as
well as a bugfix.

If any of you have write access to python source, you can help me to get
it fixed quickly.
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: backtrace.txt
Url: http://mail.scipy.org/pipermail/ipython-dev/attachments/20100713/d0fbc776/attachment-0001.txt 


More information about the IPython-dev mailing list