[IPython-dev] Error when running ipcluster

Fernando Perez fperez.net@gmail....
Wed Jul 14 13:24:27 CDT 2010


Hi Pim,

On Wed, Jul 14, 2010 at 1:16 AM, Pim Schellart <P.Schellart@astro.ru.nl> wrote:
>
> I would like to use IPython to do some basic parallelization.
> However when I execute ipcluster to setup a controller and some
> engines I get the following error:
>
> ~ $ ipcluster
> Traceback (most recent call last):
>  File "/Library/Frameworks/Python.framework/Versions/2.6/bin/ipcluster",
> line 16, in <module>
>    from IPython.kernel.ipclusterapp import launch_new_instance
> ImportError: No module named ipclusterapp
[...]
> Any idea what is going wrong here?

That script is a 0.11 series startup script, while you mention you are
running 0.10.  It seems you've somehow mixed up the installation of
the 0.10 and the 0.11 versions of IPython...  It's possible you have
in your $path a 0.11 startup ipcluster script, but the version of the
IPython package in $pythonpath is the 0.10 version...

I'd suggest cleaning up the combination and reinstalling, somehow you
have a weird hybrid...

Cheers,

f


More information about the IPython-dev mailing list