[IPython-dev] Coordinating the XREQ and SUB channels

Brian Granger ellisonbg@gmail....
Fri Jul 16 13:53:16 CDT 2010


The issue is the units of the timeout passed to poll in the ioloop.
Here is the line of code where you can see my comment about this:

http://github.com/ellisonbg/pyzmq/commit/18f5d061558a176f5496aa8e049182c1a7da64f6#L2R189

Can you try increasing/decreasing it by a factor of 1000.  As long as
you are using an inplace build, you shouldn't have to recompile.  I
need to install qt+pyqt and then I can give this a try as well.

Brian


On Fri, Jul 16, 2010 at 11:24 AM, Fernando Perez <fperez.net@gmail.com> wrote:
> On Fri, Jul 16, 2010 at 9:21 AM, Evan Patterson <epatters@enthought.com> wrote:
>> I verified that I have that commit and that I recompiled PyZMQ.
>> Unfortunately, the problem persists.
>>
>> Fernando: as a sanity check, can you confirm that you have this problem with
>> the latest version of PyZMQ?
>
> Same here.  I had rebuilt zmq/pyzmq to confirm whether the other
> problem we'd seen was gone (kernel dying when clients disconnect), and
> that one is indeed now fixed.
>
> But the CPU 100% use is still there, even when Evan's qt frontend is
> idle.  As a data point, Gerardo's, which does not yet use the ioloop,
> doesn't show the problem.
>
> Cheers,
> f
>



-- 
Brian E. Granger, Ph.D.
Assistant Professor of Physics
Cal Poly State University, San Luis Obispo
bgranger@calpoly.edu
ellisonbg@gmail.com


More information about the IPython-dev mailing list