[IPython-dev] 0.11 on RHEL5/x86

Hans Meine hans_meine@gmx....
Sun Oct 9 07:25:49 CDT 2011


Hi!

Am 08.10.2011 um 03:35 schrieb Fernando Perez:

> On Fri, Oct 7, 2011 at 4:49 PM, MinRK <benjaminrk@gmail.com> wrote:
>> I can add it to the qt import check, but we don't actually know where the
>> line is drawn - it's just somewhere between 4.4.3 and 4.7.4, which is a
>> pretty long time.
> 
> I guess we could just be a little over-conservative and do 4.7, but I
> don't know if that may shut out unnecessarily users who can't easily
> update say 4.5 or  4.6 where for all we know it works fine.

Indeed, the (really good!) Qt documentation quickly reveals that the posted exception would already vanish with 4.5:
http://doc.qt.nokia.com/stable/qtextcursor.html#document

(Of course, different issues could arise after that.)

Let me also note as an explanation for the PyQt-only upgrade that PyQt is backwards-compatible with all (OK, many ;-) ) previous Qt versions and will "just export what’s there" in the given Qt version.

HTH,
  Hans


More information about the IPython-dev mailing list