[IPython-dev] [IPython-User] PyZMQ 2.1.10

Fernando Perez fperez.net@gmail....
Thu Oct 13 20:30:38 CDT 2011


On Thu, Oct 13, 2011 at 6:05 PM, MinRK <benjaminrk@gmail.com> wrote:
> If you must use IPython 0.11 and a bdist of pyzmq, you can force pyzmq
> to install 2.1.9 with `easy_install pyzmq==2.1.9`.

Alternatively, if you know you have pyzmq 2.1.10 and don't want to
upgrade IPython at this moment, a quick and dirty fix is to manually
edit the file IPython/zmq/__init__.py, and comment out or delete these
lines towards the top:

if pyzmq_version < minimum_pyzmq_version:
    raise ImportError("IPython.zmq requires pyzmq >= %s, but you have %s"%(
                    minimum_pyzmq_version, pyzmq_version))

That should do the trick (ugly but effective).

Cheers,

f


More information about the IPython-dev mailing list