[IPython-dev] ipython qt on Windows

Fernando Perez fperez.net@gmail....
Fri Oct 28 16:27:41 CDT 2011


Hi Kevin,

On Fri, Oct 28, 2011 at 2:24 PM, Kevin Buchs <kevin.buchs@gmail.com> wrote:
> Then 2. complaint saying it "requires pyzmq >= 2.1.4, but you have 2.1.10".
> Math doesn't work out.
> Then 1. nothing.
> I tried an .msi install of version 2.1.4 of pyzmq, but still got the
> complaint about 2.1.10 not >= 2.1.4, so I suppose I have to try to figure
> out how to uninstall 2.1.10.
> Am I making some mistakes here?

Unfortunately, you're being bitten by a bug in our 0.11 version
regarding the zmq version check: we were doing simple, lexicographic
checking, where 10 comes before 4.  This has been fixed but only in
IPython master.

A few days ago I built a Windows binary installer of 0.12 which has
this bug already fixed:

http://archive.ipython.org/testing/ipython-0.12.dev.win32-setup.exe

Let us know if that helps.

Cheers,

f


More information about the IPython-dev mailing list